Can't upload picture

Posted under General

I updated the system to the latest Danbooru, but it seems something got broken somewhere, I've reverted for now will try again in a few days.

Alright, this issue has been resolved, we're up to date with Danbooru once again.

I upload them as intended i guess. Right where it says "Drag and drop a file here". Drag and drop won't work, neither does the old fashioned way via left click. When i try any of those ways it loads the file and turns green and looks like it's ready and everything is fine, but when i hit submit i get the same ol' "Error: Must choose file or specify source" error.

Yeah this issue is confusing, I would really like if you could get on that Chat to make the debugging easier than having to chat through this

Still can't upload anything. I tried adding a source for a picture, but then i get a blank page with the message "Nil location provided. Can't build URI."

PurpleMelon said:

Seems to work in chrome too now.

Okay, that is odd, perhaps it just needed to reset its cache or something weird.

And i still can't upload a lot of pictures due to some weird md5 error messages i get in both browsers. Man i give up.

PurpleMelon said:

And i still can't upload a lot of pictures due to some weird md5 error messages i get in both browsers. Man i give up.

I've updated again, could you see if some of your issues have been resolved?

I knowwww and today again the "Error: Must choose file or specify source" error in chrome. Like i don't even...
Like i don't get these errors on other sites. Never change a running system :(

Dampfnudel said:

WHY!!!???!!!
It's so fucking annoying!
Every day the same! Error this, Error that...

Could you email me the images that didn't work? I'll see if I can find out what the fuck is wrong this time I'm having a hard time reproducing the error.

just mail them to admin@allthefallen.ninja

The magic behind this is called patience...
I could upload every picture after some tries. The main problem is ths green upload box. It's causing all these problems.
Sometimes it's green, but if you finally upload your picture, it fails. Them go back, upload the picture again and try this until it works.
These are the main errors after the upload: "MD5....", "Database timed out....", "404", and one, where i forgot the number (error .....).
These pictures, i uploaded at saturday, took me 6h to upload.

I've moved the server, I'd love if you could try and upload a lot of stuff again and tell me how fast it went and if you encountered any errors.

I still can't upload any pictures with Chrome anymore. Only with Firefox and now i can't even favorite any pictures with any of the browsers anymore...

PurpleMelon said:

I still can't upload any pictures with Chrome anymore. Only with Firefox and now i can't even favorite any pictures with any of the browsers anymore...

I'm not sure what the issue with your Chrome is I've tested uploading different things with a normal user and it was working fine.

Could you open the Dev console by pressing F12 and clicking on the button console. and see if you're getting any errors showing in there.

It happens again....

The reason, why i can't upload anything is this "drag&drop"-field. It doesn't even load

Dampfnudel said:

It happens again....

The reason, why i can't upload anything is this "drag&drop"-field. It doesn't even load

I will be getting rid of the JS thing ASAP so you only have the Browse button again. (Worked a lot better in my opinion)

Iratu said:

I will be getting rid of the JS thing ASAP so you only have the Browse button again. (Worked a lot better in my opinion)

JS Uploader has been trashed, try uploading stuff now.

didn´t want to open a new thread....

since three days i try to upload images, but every time i get this message:

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:51:in `create'

is it because of the move to a new server?

Dampfnudel said:

didn´t want to open a new thread....

since three days i try to upload images, but every time i get this message:

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:51:in `create'

is it because of the move to a new server?

Is it still happening?

thatenemy said:

Is it still happening?

Error

Validation failed: Md5 confirmation doesn't match Md5
Details

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:51:in `create'

as you can see, yes... tried to look up for it on google days before. the most matching answers were:

-an internal problem with "booru"
-a problem with my ip address

Edit:

tried uploading (firefox) without any add-ons... fail
tried uploading with ie... fail

Updated

Dampfnudel said:

Error

Validation failed: Md5 confirmation doesn't match Md5
Details

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:51:in `create'

as you can see, yes... tried to look up for it on google days before. the most matching answers were:

-an internal problem with "booru"
-a problem with my ip address

Edit:

tried uploading (firefox) without any add-ons... fail
tried uploading with ie... fail

This apparently has to do with the slowness we have been experiencing for a while now. The upload gets cut off before it can finish. Unfortunately there's not much we can do about it right now, as getting better speeds would be very expensive (for now).

Strangly enough, other people seem to have no trouble uploading stuff, which may have to do with timing or upload size (I have no idea). I'll ask if there's anything that can be done about it.

thatenemy said:

This apparently has to do with the slowness we have been experiencing for a while now. The upload gets cut off before it can finish. Unfortunately there's not much we can do about it right now, as getting better speeds would be very expensive (for now).

Strangly enough, other people seem to have no trouble uploading stuff, which may have to do with timing or upload size (I have no idea). I'll ask if there's anything that can be done about it.

funny thing is, the images, i tried to upload weren´t big.. but.. you know what?

i can wait... better times will come... ;D

Dampfnudel said:

funny thing is, the images, i tried to upload weren´t big.. but.. you know what?

i can wait... better times will come... ;D

Our reverse proxy has been upgraded. This means speeds should be much better than before. Can you try uploading something and see if it works properly now?

thatenemy said:

Our reverse proxy has been upgraded. This means speeds should be much better than before. Can you try uploading something and see if it works properly now?

have read your answer way too late.. look in the comments-section.. :D

Dampfnudel said:

It get this message: "Validation failed: Md5 confirmation doesn't match Md5"

Me too!

In fact the entire message is:

-
Error

Validation failed: Md5 confirmation doesn't match Md5
Details

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:55:in `create'

-

How do we fix this?

tyciol said:

Me too!

In fact the entire message is:

-
Error

Validation failed: Md5 confirmation doesn't match Md5
Details

ActiveRecord::RecordInvalid exception raised
app/logical/upload_service.rb:42:in `start!'
app/controllers/uploads_controller.rb:55:in `create'

-

How do we fix this?

Still getting the error? That's weird. I'll ask iratu what can be done.

Dampfnudel said:

@thatenemy

15 uploads per day? since when and why? the first time after years that i got such a message :(

That is very strange (even used-to-be very active users have a limit of 15 uploads). We'll look into it.

1